kingdong020543
管理员
管理员
  • UID6
  • 粉丝51
  • 关注2
  • 发帖数141
  • 喜欢达人
  • 社区居民
  • 忠实会员
  • 原创写手
阅读:1152回复:0

如何迁移现有的应用程序

楼主#
更多 发布于:2015-08-20 14:44
如何迁移现有的应用程序
   从一个版本的vuforia SDK升级到下一个发布版本,建议你参照你的SDK版本迁移指南定义的步骤。本文标明了从以前版本的vuforia平台升级项目时你应该注意到的API和SDK的结构变化。

vuforia4迁移到vuforia 5


Vuforia5 的变化 文章介绍了已经推出的新API,vuforia 5已经支持数字眼镜和回调追踪状态的能力。这些变化将不会影响迁移的vuforia项目,无论使用Java和C++的API。

   有一个重构的Unity的API和SDK文件夹结构, Unity项目迁移到vuforia5时需要进行修改,参见:
迁移Unity项目到vuforia 5

   使用vuforia 4测试版SDK开发的数字眼镜应用程序将需要一个新的许可证密钥,如果开发的是视频透视眼镜,参阅 迁移数字眼镜应用程序到vuforia 5

   如何升级现有的项目的一般建议,请查阅开发项目的
SDK版本迁移的文章。

参阅:
如何将一个Android项目
如何将一个iOS项目
如何将一个统一的项目

vuforia3迁移到vufroria 4

   Vuforia 4.0 SDK引进了一些重大变化到vuforia API。

1。所有的vuforia 4.0应用程序需要从
vuforia许可管理实现一个独特的许可证密钥。
2。ImageTracker类已经被ObjectTracker类取代,作为物体和图像统一的追踪类型。
2。智能地形API使用一个新的命令设计模式,它依赖于一个SmartTerrainBuilder类来管理由智能地形产生的重建。
3。为Unity引进一个新的Vuforia命名空间。你需要在开头添加下面的引用。



  1. <font size="3">using Vuforia;</font>
复制代码
参阅:
vuforia 4迁移 如何转变你的现有代码到vuforia 4.0。

SDK迁移向导迁移现有文件,Vuforia项目必要的修改和建议。

欢迎分享

游客

返回顶部